re = /(?:youtube(?:-nocookie)?\.com\/(?:[^\/]+\/.+\/|(?:v|e(?:mbed)?)\/|.*[?&]v=)|youtu\.be\/)([^"&?\/ ]{11})/
str = 'http://youtu.be/dQw4w9WgXcQ ...
http://www.youtube.com/embed/dQw4w9WgXcQ ...
http://www.youtube.com/watch?v=dQw4w9WgXcQ ...
http://www.youtube.com/?v=dQw4w9WgXcQ ...
http://www.youtube.com/v/dQw4w9WgXcQ ...
http://www.youtube.com/e/dQw4w9WgXcQ ...
http://www.youtube.com/user/username#p/u/11/dQw4w9WgXcQ ...
http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/dQw4w9WgXcQ ...
http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ ...
http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end