import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:youtube(?:-nocookie)?\\.com\\/(?:[^\\/]+\\/.+\\/|(?:v|e(?:mbed)?)\\/|.*[?&]v=)|youtu\\.be\\/)([^\"&?\\/ ]{11})";
final String string = "http://youtu.be/dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/embed/dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/watch?v=dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/?v=dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/v/dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/e/dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/user/username#p/u/11/dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/sandalsResorts#p/c/54B8C800269D7C1B/0/dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/watch?feature=player_embedded&v=dQw4w9WgXcQ ...\n"
+ "http://www.youtube.com/?feature=player_embedded&v=dQw4w9WgXcQ ...";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}