#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^([s|S][e|E][l|L][e|E][c|C][t|T])\s([a-zA-Z0-9\-_]+|\*),?([a-zA-Z0-9\-_]+)*\s([f|F][r|R][o|O][m|M])\s([a-zA-Z0-9\-_]+),?([a-zA-Z0-9\-_]+)*(.*);$"
Local $sString = "SELECT * FROM foo WHERE;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")