import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([s|S][e|E][l|L][e|E][c|C][t|T])\\s([a-zA-Z0-9\\-_]+|\\*),?([a-zA-Z0-9\\-_]+)*\\s([f|F][r|R][o|O][m|M])\\s([a-zA-Z0-9\\-_]+),?([a-zA-Z0-9\\-_]+)*(.*);$";
final String string = "SELECT * FROM foo WHERE;\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}