// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^([s|S][e|E][l|L][e|E][c|C][t|T])\s([a-zA-Z0-9\-_]+|\*),?([a-zA-Z0-9\-_]+)*\s([f|F][r|R][o|O][m|M])\s([a-zA-Z0-9\-_]+),?([a-zA-Z0-9\-_]+)*(.*);$").unwrap();
let string = "SELECT * FROM foo WHERE;
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}