package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:Transaction\s\(\s|transaction\:\s|transaction\sId\s|\*\')(?P<transaction>\d{4,5})`)
var str = `Transaction ( 12345 )
03/14/2019 18:11:53.392-> Level:8, ( 987654321, 21, 0, *'12345'*, null, TO_DATE('2019/03/01 00:00:00','YYYY/MM/DD
Not included because custom value doesn't match: transaction: 12345
03/14/2019 18:10:12.685-> Level:8, Fixing transaction Id 12345
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}