use strict;
my $str = 'Transaction ( 12345 )
03/14/2019 18:11:53.392-> Level:8, ( 987654321, 21, 0, *\'12345\'*, null, TO_DATE(\'2019/03/01 00:00:00\',\'YYYY/MM/DD
Not included because custom value doesn\'t match: transaction: 12345
03/14/2019 18:10:12.685-> Level:8, Fixing transaction Id 12345
';
my $regex = qr/(?:Transaction\s\(\s|transaction\:\s|transaction\sId\s|\*\')(?P<transaction>\d{4,5})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}