$re = '/(?:Transaction\s\(\s|transaction\:\s|transaction\sId\s|\*\')(?P<transaction>\d{4,5})/m';
$str = 'Transaction ( 12345 )
03/14/2019 18:11:53.392-> Level:8, ( 987654321, 21, 0, *\'12345\'*, null, TO_DATE(\'2019/03/01 00:00:00\',\'YYYY/MM/DD
Not included because custom value doesn\'t match: transaction: 12345
03/14/2019 18:10:12.685-> Level:8, Fixing transaction Id 12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);