import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:Transaction\\s\\(\\s|transaction\\:\\s|transaction\\sId\\s|\\*\\')(?P<transaction>\\d{4,5})";
final String string = "Transaction ( 12345 )\n"
+ "03/14/2019 18:11:53.392-> Level:8, ( 987654321, 21, 0, *'12345'*, null, TO_DATE('2019/03/01 00:00:00','YYYY/MM/DD\n"
+ " Not included because custom value doesn't match: transaction: 12345\n"
+ " 03/14/2019 18:10:12.685-> Level:8, Fixing transaction Id 12345\n\n\n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}