using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"rt_view_product.*user_id";
string input = @"rt_view_product something user_id
foo bar user_id
foo user_id rt_view_productuser_id";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}