package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)rt_view_product.*user_id`)
var str = `rt_view_product something user_id
foo bar user_id
foo user_id rt_view_productuser_id`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}