re = /rt_view_product.*user_id/m
str = 'rt_view_product something user_id
foo bar user_id
foo user_id rt_view_productuser_id'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end