$re = '/rt_view_product.*user_id/m';
$str = 'rt_view_product something user_id
foo bar user_id
foo user_id rt_view_productuser_id';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);