import re
regex = re.compile(r"<p>\K([^><]+)(?=</p>)", flags=re.MULTILINE)
test_str = ("<p> <img src=\"spas01.jpg\" alt=\"\" width=\"630\" height=\"480\"></p>\n"
"<p style=\"text-align: right;\"><a href=\"spas.html\">Spas</a></p>\n"
"<p>My Site Content [...]</p>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")