re = /<p>\K([^><]+)(?=<\/p>)/m
str = '<p> <img src="spas01.jpg" alt="" width="630" height="480"></p>
<p style="text-align: right;"><a href="spas.html">Spas</a></p>
<p>My Site Content [...]</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end