using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"r(\d{1,2})-(\d{1,2})s(\d{1,2})";
string input = @"r4-10s5r6-7s8";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}