const regex = /r(\d{1,2})-(\d{1,2})s(\d{1,2})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('r(\\d{1,2})-(\\d{1,2})s(\\d{1,2})', 'g')
const str = `r4-10s5r6-7s8`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}