$re = '/r(\d{1,2})-(\d{1,2})s(\d{1,2})/';
$str = 'r4-10s5r6-7s8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);