package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`r(\d{1,2})-(\d{1,2})s(\d{1,2})`)
var str = `r4-10s5r6-7s8`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}