using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![A-Z][a-z])([!?.])(?=\s*[A-Z])\s*";
string substitution = @"\1\n";
string input = @"Mr. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Adam Jones Jr. thinks he didn't. In any case, this isn't true... Well, with a probability of .9 it isn't. What a great movie! I loved it. I loved it!!! Did you??? I did.!? Not really it was bad!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}