import Foundation
let pattern = #"(?<![A-Z][a-z])([!?.])(?=\s*[A-Z])\s*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"Mr. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Adam Jones Jr. thinks he didn't. In any case, this isn't true... Well, with a probability of .9 it isn't. What a great movie! I loved it. I loved it!!! Did you??? I did.!? Not really it was bad!"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)