const regex = /(?<![A-Z][a-z])([!?.])(?=\s*[A-Z])\s*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<![A-Z][a-z])([!?.])(?=\\s*[A-Z])\\s*', 'g')
const str = `Mr. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Adam Jones Jr. thinks he didn't. In any case, this isn't true... Well, with a probability of .9 it isn't. What a great movie! I loved it. I loved it!!! Did you??? I did.!? Not really it was bad!`;
const subst = `\1\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);