re = /(?<![A-Z][a-z])([!?.])(?=\s*[A-Z])\s*/
str = 'Mr. Smith bought cheapsite.com for 1.5 million dollars, i.e. he paid a lot for it. Did he mind? Adam Jones Jr. thinks he didn\'t. In any case, this isn\'t true... Well, with a probability of .9 it isn\'t. What a great movie! I loved it. I loved it!!! Did you??? I did.!? Not really it was bad!'
subst = '\\1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result