using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d*[a-zA-Z][a-zA-Z0-9]*$";
string input = @"d
David
Billie Joe
Han-So
-Hans
Hans-
Hans--Gretel
Hans-Gretel
dsfsdfsdf
44444444
fsdfsdf324324324
^\d*[a-zA-Z][a-zA-Z0-9]*$
sadasdsa3333
dfsdfsdf
34343434";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}