import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d*[a-zA-Z][a-zA-Z0-9]*$";
final String string = "d\n"
+ "David\n"
+ "Billie Joe\n"
+ "Han-So\n"
+ "-Hans\n"
+ "Hans-\n"
+ "Hans--Gretel\n"
+ "Hans-Gretel\n"
+ "dsfsdfsdf\n"
+ "44444444\n"
+ "fsdfsdf324324324\n"
+ "^\\d*[a-zA-Z][a-zA-Z0-9]*$\n"
+ "sadasdsa3333\n"
+ "dfsdfsdf\n"
+ "34343434";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}