import Foundation
let pattern = #"^\d*[a-zA-Z][a-zA-Z0-9]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
d
David
Billie Joe
Han-So
-Hans
Hans-
Hans--Gretel
Hans-Gretel
dsfsdfsdf
44444444
fsdfsdf324324324
^\d*[a-zA-Z][a-zA-Z0-9]*$
sadasdsa3333
dfsdfsdf
34343434
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)