$re = '/^\d*[a-zA-Z][a-zA-Z0-9]*$/m';
$str = 'd
David
Billie Joe
Han-So
-Hans
Hans-
Hans--Gretel
Hans-Gretel
dsfsdfsdf
44444444
fsdfsdf324324324
^\\d*[a-zA-Z][a-zA-Z0-9]*$
sadasdsa3333
dfsdfsdf
34343434';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);