import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:/(?:[0-9A-Za-z-]+/)*[&?=0-9A-Za-z-]*)?$";
final String string = "SHOULD MATCH\n"
+ "/\n"
+ "/section\n"
+ "/section/article-1\n"
+ "/section/article-1/\n"
+ "/section/article-1?x=y&hello=world\n\n"
+ "SHOULD NOT MATCH\n"
+ "section/article-1\n"
+ "/section/!$*\n"
+ "/x(1)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}