$re = '~^(?:/(?:[0-9A-Za-z-]+/)*[&?=0-9A-Za-z-]*)?$~m';
$str = 'SHOULD MATCH
/
/section
/section/article-1
/section/article-1/
/section/article-1?x=y&hello=world
SHOULD NOT MATCH
section/article-1
/section/!$*
/x(1)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);