use strict;
my $str = '\\24s904dS\\24sr4d2\\24x\\\\y\\\\12z:234F\\\\3dRl\\24o980\\24foo:bar\\24abcd';
my $regex = qr/.*\\24(.*:.*?)\\24/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}