re = /.*\\24(.*:.*?)\\24/
str = '\\24s904dS\\24sr4d2\\24x\\\\y\\\\12z:234F\\\\3dRl\\24o980\\24foo:bar\\24abcd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end