$re = '/.*\\\\24(.*:.*?)\\\\24/';
$str = '\\24s904dS\\24sr4d2\\24x\\\\y\\\\12z:234F\\\\3dRl\\24o980\\24foo:bar\\24abcd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);