const regex = /<moolinkx pageid="([^"]+)">([^<]+)<\/moolinkx>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<moolinkx pageid="([^"]+)">([^<]+)<\\\/moolinkx>', 'g')
const str = `<p>blabalblahhh <moolinkx pageid="121">text to click</moolinkx> blablabah.</p>
<p>Another <moolinkx pageid="128">text to clickclick</moolinkx> again blablablah.</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}