// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<moolinkx pageid="([^"]+)">([^<]+)<\/moolinkx>"#).unwrap();
let string = "<p>blabalblahhh <moolinkx pageid=\"121\">text to click</moolinkx> blablabah.</p>
<p>Another <moolinkx pageid=\"128\">text to clickclick</moolinkx> again blablablah.</p>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}