#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([-+]?[0-9]+[-,])*[+-]?[0-9]+$"
Local $sString = "123,123,10" & @CRLF & _
"10,10" & @CRLF & _
"25" & @CRLF & _
"-25,10" & @CRLF & _
"10-25-30" & @CRLF & _
"-15,-40"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")