$re = '/^([-+]?[0-9]+[-,])*[+-]?[0-9]+$/m';
$str = '123,123,10
10,10
25
-25,10
10-25-30
-15,-40';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);