re = /^([-+]?[0-9]+[-,])*[+-]?[0-9]+$/m
str = '123,123,10
10,10
25
-25,10
10-25-30
-15,-40'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end