using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([-+]?[0-9]+[-,])*[+-]?[0-9]+$";
string input = @"123,123,10
10,10
25
-25,10
10-25-30
-15,-40";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}