import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\\{(\\s*Form::\\w*\\((?:[^\\}]*(?:\\}[^\\}]+)*))\\}\\}";
final String string = "{{ Form::text('twitter', Input::old('twitter'), \n"
+ " array(\n"
+ " 'class'=>'form-control} ',\n"
+ " 'placeholder'=>'E.g http://www.twitter.com/MyTwitterPage'\n"
+ " ))\n\n"
+ " }}\n"
+ "{{ Form::text('twitter', Input::old('twitter'), \n"
+ " array(\n"
+ " 'class'=>'form-control ',\n"
+ " 'placeholder'=>'E.g http://www.twitter.com/MyTwitterPage'\n"
+ " ))\n\n"
+ " }}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}