import re
regex = re.compile(r"\{\{(\s*Form::\w*\((?:[^}]*(?:}[^}]+)*))}}")
test_str = ("{{ Form::text('twitter', Input::old('twitter'), \n"
" array(\n"
" 'class'=>'form-control} ',\n"
" 'placeholder'=>'E.g http://www.twitter.com/MyTwitterPage'\n"
" ))\n\n"
" }}\n"
"{{ Form::text('twitter', Input::old('twitter'), \n"
" array(\n"
" 'class'=>'form-control ',\n"
" 'placeholder'=>'E.g http://www.twitter.com/MyTwitterPage'\n"
" ))\n\n"
" }}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")