const regex = /\{\{(\s*Form::\w*\((?:[^}]*(?:}[^}]+)*))}}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\{\\{(\\s*Form::\\w*\\((?:[^}]*(?:}[^}]+)*))}}', 'g')
const str = `{{ Form::text('twitter', Input::old('twitter'),
array(
'class'=>'form-control} ',
'placeholder'=>'E.g http://www.twitter.com/MyTwitterPage'
))
}}
{{ Form::text('twitter', Input::old('twitter'),
array(
'class'=>'form-control ',
'placeholder'=>'E.g http://www.twitter.com/MyTwitterPage'
))
}}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}