$re = '/\{\{(\s*Form::\w*\((?:[^}]*(?:}[^}]+)*))}}/';
$str = '{{ Form::text(\'twitter\', Input::old(\'twitter\'),
array(
\'class\'=>\'form-control} \',
\'placeholder\'=>\'E.g http://www.twitter.com/MyTwitterPage\'
))
}}
{{ Form::text(\'twitter\', Input::old(\'twitter\'),
array(
\'class\'=>\'form-control \',
\'placeholder\'=>\'E.g http://www.twitter.com/MyTwitterPage\'
))
}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);