const regex = /([^<h4>]).*([^<\/h4>])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^<h4>]).*([^<\\\/h4>])', '')
const str = `<h4>name: Sergey</h4><h4>lastName: Bovyrin</h4><h4>email: serbovyr@gmail.com</h4><h4>phone: 3434534554</h4>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}