import re
regex = re.compile(r"([^<h4>]).*([^<\/h4>])")
test_str = "<h4>name: Sergey</h4><h4>lastName: Bovyrin</h4><h4>email: serbovyr@gmail.com</h4><h4>phone: 3434534554</h4>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")