import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^ ]*) ([^ ]*) ([^ ]*) (\\[(.*)\\]) (\\\"(.*)\\\") ([0-9]*) ([0-9]*) (\\\"(.*)\\\") (\\\"(.*))";
final String string = "70.39.184.135 - - [10/Dec/2014:19:20:59 +0530] \"GET /wp-content/themes/wplms/js/bootstrap.min.js?ver=3.8.5 HTTP/1.1\" 200 29074 \"http://etlhive.com/redhat-linux-training-in-pune/\" \"UCWEB/2.0 (Symbian; U; S60 V3; en-US; NokiaC5-00.2) U2/1.0.0 UCBrowser/9.2.0.336 U2/1.0.0 Mobile\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}