import Foundation
let pattern = #"([^ ]*) ([^ ]*) ([^ ]*) (\[(.*)\]) (\"(.*)\") ([0-9]*) ([0-9]*) (\"(.*)\") (\"(.*))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"70.39.184.135 - - [10/Dec/2014:19:20:59 +0530] "GET /wp-content/themes/wplms/js/bootstrap.min.js?ver=3.8.5 HTTP/1.1" 200 29074 "http://etlhive.com/redhat-linux-training-in-pune/" "UCWEB/2.0 (Symbian; U; S60 V3; en-US; NokiaC5-00.2) U2/1.0.0 UCBrowser/9.2.0.336 U2/1.0.0 Mobile""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}