#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\/cue\/(?<WHO>[oe\d\-\,]+)\/(?<ACTION>[A-Za-z\\_]+)\/(?<XYZ>[\_\,\`\d\.\-]+)\/(?<TOTALTIME>\d+)"
Local $sString = "/cue/1-20-o/COLOR/1,2,3~4,5,6/3000/" & @CRLF & _
"/cue/1-20-o/COLOR/1,2,3/3000/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")