package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\/cue\/(?<WHO>[oe\d\-\,]+)\/(?<ACTION>[A-Za-z\\_]+)\/(?<XYZ>[\_\,\`\d\.\-]+)\/(?<TOTALTIME>\d+)`)
var str = `/cue/1-20-o/COLOR/1,2,3~4,5,6/3000/
/cue/1-20-o/COLOR/1,2,3/3000/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}