$re = '/\/cue\/(?<WHO>[oe\d\-\,]+)\/(?<ACTION>[A-Za-z\\\\_]+)\/(?<XYZ>[\_\,\`\d\.\-]+)\/(?<TOTALTIME>\d+)/m';
$str = '/cue/1-20-o/COLOR/1,2,3~4,5,6/3000/
/cue/1-20-o/COLOR/1,2,3/3000/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);