using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/cue\/(?<WHO>[oe\d\-\,]+)\/(?<ACTION>[A-Za-z\\_]+)\/(?<XYZ>[\_\,\`\d\.\-]+)\/(?<TOTALTIME>\d+)";
string input = @"/cue/1-20-o/COLOR/1,2,3~4,5,6/3000/
/cue/1-20-o/COLOR/1,2,3/3000/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}